Abby's Guide to Plasma TVs
Username Password
Home Discussions Reviews More Guides

Member Profile


adalect

Name Unknown
Email Address private
AIM
YIM
ICQ
Gender
Age
Location
Personal Quote
Privileges Normal user
Rank
Points 2
Number of Posts 2
Number of Reviews 0
Date Joined Mar 27, 2009
Date Last Access Oct 3, 2009 7:00 pm
adalect's last  
Thanks
#1   Mar 27, 2009 11:19 pm
Thanks guys for your speed replies. I will try everything that was suggested here and that should solve my problems.
Beam Serenity Plus (SP800) Rusted Plug
#2   Mar 27, 2009 5:12 pm
Hi. I have an almost 7-year old Beam Serenity Plus that I use at my home.



It has been a good vacuum but now I notice it doesn't work as well as before. When I use it now, the vacuum flickers on and off every 20 seconds for some reason. I find that I have to press up on the top part of the vacuum tube, where the plug for power from the vacuum head fits in. I have recently took a look at the plug and found one of its pins is rusted badly.



The original pin colour is yellow, so you have an idea of how bad the rust is. The vacuum itself is still in good shape, so does anybody know how I can get this rust off? I find it a bother to throw away an otherwise perfectly good vacuum.

Thanks for the help.

EDIT: I copied a link and pasted it here for the pictures, but the pictures didn't embed. I then found the attach picture button, so that's why I edited this post.
Plasma TVs Guide   •   Discussions  Reviews  
AbbysGuide.com   About Us   Terms of Use   Privacy Policy   Contact Us
Copyright 1998-2019 AbbysGuide.com. All rights reserved.
Site by Take 42